Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
How can a user add the "Has Breached" column onto the incident table for reporting? - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • How can a user add the "Has Breached" column onto the incident table for reporting?
KB0685868

How can a user add the "Has Breached" column onto the incident table for reporting?


2101 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Issue Summary

How can a user add the "Has Breached" column onto the incident table for reporting?

  

Cause

This cannot be accomplished via the standard incident table view. However, the user can accomplish this through the use of Database Views.


Resolution

As per the above, this type of robust reporting can be accomplished through the use of Database Views.

Here is the documentation for them: https://docs.servicenow.com/csh?topicname=c_DatabaseViews.html&version=latest

Database views join tables for reporting purposes. For example, the customer can create a database view to join the incident table to the task_sla table. 

In fact, this joined table already exists in the customer's instance.

To navigate to it, do the following:

In the left navigator, type in "Database views" and click into System Definition > Database Views. This will bring the customer to all the database views that already exist in their system.

Please note that "incident_sla" already exists (this is a joining of the incident table to the task_sla table).

To get to that table directly, in the left navigator type "incident_sla.list" and hit enter.

From this table view, the customer can add the "Has Breached" column.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.