Issue
Have your users reported that they can no longer see the New or Edit buttons on a list?
Have they stated they cannot create a new record on a table?
Facts
If only one user is experiencing the issue, begin troubleshooting by testing in incognito (private) mode. Also, clear the browser cache, restart the browser, and test again to determine if this resolves the isolated problem.
Release
All Releases
Cause
If users are encountering these issues, then there are a few places that need to be checked to identify the source of their restricted access:
- ACLs
- List Control record
- UI Action record
- Role Association
Resolution
ACLs
Admins will need to review the ACL configuration in their environment and review the specific ACLs associated to the table their users are trying to access. For example, if the New button is missing from the incident table, admins will want to review the incident/create ACL. If there is not a specific create ACL on the incident table, then they will need to review the task/create ACL as well as the */create ACL. The Requires Role field and Script fields should be looked at to confirm that users are not being restricted.
List Control
On any table, the admin can right click in the header near a column name > Configure > List Control:
There are several areas on the List Control record, where users can show/hide the New and Edit buttons.
-Omit new button checkbox
-Omit edit button checkbox
- If either of the Omit checkboxes are populated, Admins can uncheck this box and the buttons will appear on the list as expected.
-New roles list
-Edit roles list
- If there are any roles populating these roles list fields, ensure they are associated to your impacted users.
-Omit new condition script box
-Omit edit condition script box
- Confirm that users are not being inhibited/restricted by the script if either of these boxes are populated.
UI Actions
If checking the ACL and the List Control record does not explain why users cannot see the buttons, then the Ui action record will need to be reviewed. Often times, customers will add in a role requirement directly into the Condition or Script fields, or they will add in some other requirement (not necessarily role related, such as calling a script include) which will prevent users from accessing that UI action as well.
Admins will want to review the UI action and ensure that one of the List checkboxes is selected, and that their user is not failing access due to the Requires Role embedded list, Condition field, or the Script box.
Roles
The issue could also be due to something simple like Role association. If there are role requirements in the ACL, List Control, and UI Action configurations, then the user will not have access to the New/Edit buttons if they are missing the specified roles.