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Cannot update content management pages due to "Duplicate entry" error - Support and Troubleshooting
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  • Cannot update content management pages due to "Duplicate entry" error
KB0685477

Cannot update content management pages due to "Duplicate entry" error


439 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Updating any content management pages (content_page) results in the error similar to below:

java.sql.BatchUpdateException: Duplicate entry 'eb8044e86f42ce00d0ca9c0cbb3ee491-enroll_password_reset' for key 'content_page_index0'

Invalid Update

Release

All releases that still use Content Management System (CMS)

Cause

The content page is being updated in a different domain.

Resolution

Switch to the same domain as the record's domain prior to updating the record. In most cases the record (content_page) would be in global domain but the user doing the update is in a different domain.

Related Links

This behavior is an expected one. When the user is in a different domain any update to any record that is not the same as the user's domain would result in the system creating a new record in the user's domain. For example, if the record is in global domain but the user is in MSP domain an update to the global domain record would insert a copy of that record (with the change) to MSP domain.

In the case of CMS, since CMS is not domain supported so inserting another record with similar "URL suffix" would result in the error above.


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