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Symptoms


Date Picker on Service Portal does not work as expected. It changes date to the current date when clicked the first time and does not let you change the date. You also see some console erros like the ones below.

Release


All Supported

Environment


Service Portal

Cause


This happens when you open a record from a Data Table widget with the filter enabled, see attached.

Resolution


Remove the filter from the Data Table widget. 

  • Go to the page where the list of record is displayed (eg. /sp?id=list&table=incident).
  • CTRL + Click on the widget and select "Instance Options"
  • Uncheck "Enable Filter"

Additional Information


PRB1194824

https://docs.servicenow.com/bundle/jakarta-servicenow-platform/page/build/service-portal/concept/sp-example-widgets.html#ariaid-title12

Article Information

Last Updated:2018-05-01 05:48:42
Published:2018-04-26