Issue
Symptoms
Wizard Launcher is not working on Service Portal.
Release
All releases
Cause
This is expected behavior.
As per development team, there is currently no way to integrate Wizards, they are not currently supported, and we currently have no plan to integrate them.
If there is sufficient customer interest in a Service Portal solution that satisfies the same need as a Wizard, this may be revisited in a future release.
Resolution
A workaround is to use Record Producers instead of Wizard Launcher.
Additional Information
Wizards currently only work in Service Catalog Platform UI:
https://docs.servicenow.com/csh?topicname=wizards.html&version=latest