Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Creation of Identification Inclusion Rules causes duplicate CIs during Discovery - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Creation of Identification Inclusion Rules causes duplicate CIs during Discovery
KB0685031

Creation of Identification Inclusion Rules causes duplicate CIs during Discovery


4700 Views Last updated : Jul 22, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

After creating Identification Inclusion Rules for a CI Class and running Discovery, duplicate CIs are created.

Release

Any where Identification Inclusion Rules can be created.

Cause

Identification inclusion rule doesn't prevent records to be added into be CMDB. Instead, based on Inclusion rule, CI gets added or updated into CMDB during the identification process. Generally, inclusion rules shouldn't be created based on criterion attribute as this can lead to the creation of duplicate CIs.

Resolution

The example below illustrates how creation of Identification Inclusion Rules can lead to duplicate CIs:

For example you are creating an identification rule on windows server: 

1. You have 'name' as one of your criterion attributes 
2. Also, in the identifier inclusion rule, you add a condition where OS Version = 'Linux' 

Now you run the discovery on Windows server name = WS1 and OS Version ='Windows' 

So, IRE will look for Name matching and check if OS Version='Linux' is already in CMDB. In this case, its not true and it will create a record with WS1 where OS version = "Windows" 

Now, you run the same discovery and , IRE will look for Name matching and check if OS Version='Linux' is already in CMDB. In this case, its not true and it will create another record with WS1 where OS version = "Windows" (now you have 2 entries) 

But if you run the discovery with same but OS Version ='Linux' and IRE will look for Name matching and check if OS Version='Linux' is already in CMDB. In this case, its not true and it will create a record with WS1 where OS version = "Linux" (now you have 3 entries) 

You run the last run discovery with same and OS Version ='Linux' and IRE will look for Name matching and check if OS Version='Linux' is already in CMDB. In this case, yes it is there and it will simply update the record ( you still have 3 entries) 

Hence: So, Inclusion rule does the matching and update only which are matched otherwise insert every time you run the discovery. 

In Summary:

  1. Inclusion rule doesn't prevent records to be added into be CMDB 
  2. Don't create identification inclusion rule on criterion attributes 
  3. Wrongly created inclusion rule can cause duplicates. 
  4. Additional Information

Related Links

Create identification inclusion rule


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.