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Symptoms


Search results are different between two instances. This can happen both on the Platform UI and Service portal. In one results returned are very specific to the search terms and in the other they are not.

Release


All supported

Cause


Default Query mode is different in the two instances. One might be in the "Default" mode and the other in the "AND_OR" mode.

Resolution


Open the Text Index record for the table having the issue on both instances. You can find the text indexed tables by navigating to System Definition > Text Indexes. Confirm that the Default Query mode is the same on both

Additional Information


https://docs.servicenow.com/bundle/kingston-platform-administration/page/administer/search-administration/task/configure-table-query-mode.html

Article Information

Last Updated:2018-04-18 06:47:20
Published:2018-04-17