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Expected fields are unavailable when creating a new template - Support and Troubleshooting
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KB0684435

Expected fields are unavailable when creating a new template


3526 Views Last updated : Jul 22, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

When trying to create a new template, the template editor interface does not show certain fields that should be available or there is no option to save as a template in the access control list on the custom table u_cmdb_ci_business_application.* fields. 

Release

All supported releases

Cause

This issue may be caused by the following: 

  • The user has insufficient write permissions to specific fields, which prevents the fields from appearing in the template editor. 
  • There is a missing or restrictive access control list (ACL) in the table that may prevent saving as a template, or there are conditions in the ACL for which the user's access does not meet. 

Resolution

To resolve this and allow users to save a record as a template, you can create a save_as_template ACL operation on the particular table. The ACL can be specific to one field or a wildcard that allows all fields in the table to be available in templates. 

Related Links

For more information, see the product documentation on Access Control List rules.


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