Issue
The max_waiters property setting can cause issues with Service Portal and other features that rely heavily on requests, such as Chat and Connect. It can lead to:
- Blank pages
- Pages that seem to load but never complete
- Various other issues with request-based features
Look for the following in the application logs:
"WARNING *** WARNING *** GlideRequestManager:Request ignored: <some_transaction>"
Release
- Kingston
- Jakarta Patch 6 and beyond
- Istanbul Patch 11 and beyond
Cause
A temporary fix (adding and setting the system property com.glide.request.max_waiters) was applied to an instance to resolve a Chat-related issue. Later, a permanent fix for the same issue was applied to the instance. However, the temporary fix was not removed after the permanent fix was applied, which resulted in the same issue reappearing that the temporary fix was intended to resolve.
Resolution
- Go to the property.
- Delete the value so there is no value.
- Save the record. This makes sure that the value of 20 does not get cached when you delete the property.
- Delete the property completely from your instance.
- In scripts background, run gs.print(gs.getProperty('com.glide.request.max_waiters')); to verify the cached value has been removed. You should expect to see a value of 'null'
If you get any other value, you will have to create a standard change in NowSupport to restart the instance, which will clear the cached value. To do this, follow steps outlined in the knowledge article, Standard Change: Node restarts using Datacenter