Issue
When an instance is upgraded to an available fix/patch, some associated Problems for a previous Service Portal issue might still occur, despite the mentioned fix target.
Cause
The reason the issue is still reproducible after the upgrade is most likely due to a custom widget being used instead of the out of the box widget. When a fix is forwarded, the custom widgets stay unaffected. Only out of the box widgets receive the fix provided by the upgrade fix or patch.
Resolution
1 - In case the previous customization is no longer needed, revert to the out of the box widget entirely.
2 - If the existing customization is required, first clone the widget, or save/backup all its content to be re-applied later.
3 - Check the Widget Instance in Page Editor, and edit the "Widget" field. Switch the custom Widget to the OOB one.
4 - After reverting to the OOB widget, add the required customization on top of it, so that all the fixes are in place. In order to do this, the fixed out of the box widget may need to be cloned again, and customizations need to be added to the cloned copy.