Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Macro variables do not display on Service Portal without a macro widget - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Macro variables do not display on Service Portal without a macro widget
KB0683339

Macro variables do not display on Service Portal without a macro widget


8545 Views Last updated : Jun 6, 2025 public Copy Permalink English (Original)
  • English (Original)
  • Japanese
KB Summary by Now Assist

Issue

Macro variables do not display on Service Portal without a macro widget.

Cause

Service Portal is built on Angular whereas UI Macros are built on Jelly, which will not work in Service Portal.

Resolution

  • To support macros in Service Portal, a widget with the equivalent macro functionality needs to be implemented for the portal.
  • The widget field on the macro variable form needs to point to this Service Portal widget.

Related Links

To implement a macro-type widget for the Service Portal, see the following documentation:

  • Replace a Service Catalog form script with a widget
  • Supported Service Catalog variable types
  • UI Macros

The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.