Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Field messages displayed for variables get removed/hidden once the variable value changes - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Field messages displayed for variables get removed/hidden once the variable value changes
KB0683314

Field messages displayed for variables get removed/hidden once the variable value changes


2403 Views Last updated : Jan 28, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Field messages that are initially displayed for variables (or form fields) are removed/hidden after the value in the variable (or field) changes.

Release


Jakarta and onward

Cause


The use of g_form.showFieldMsg() (or the legacy g_form.showErrorBox()) to display these field messages are now getting hidden as per the design of the platform starting in Jakarta.

Resolution


As this is now how it's designed in the platform starting with Jakarta release the workaround would be to use the out-of-the-box Help Text functionality.

https://docs.servicenow.com/csh?topicname=t_DefineHelpInformation.html&version=latest

Additional Information


A known problem, PRB1195721, has been opened for this and development has confirmed it's the desired behavior.

"This is the desired behavior. The same happened in platform form as well. Catalog Forms had a bug which was fixed in Jakarta and now both platform form and catalog form have the same behavior where field messages goes away when the filed value is updated."


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.