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User ID does not passover from Service Portal external login screen to SSO Login page. - Support and Troubleshooting
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KB0683230

User ID does not passover from Service Portal external login screen to SSO Login page.


1258 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


When you click "User External Login" on Service Portal Login page, there is a User ID field. When you enter your User ID in this field and click Login, you get redirected to external authentication page. On this page, the username field is blank, i.e. the User ID from previous screen did not pass over to this screen. 

 

Steps to reproduce:

  1. On an instance with SSO enabled, navigate to https://instancename.service-now.com/sp
  2. Below the Login button, click the "User external login" link.
  3. This will prompt you for only User ID.
  4. Enter the User ID and click submit.
  5. You will get redirected to SSO Login page.

Expected behavior: Notice the Username field is empty.

Actual behavior: The Username field should have populated with the User ID field from previous screen.

Release


All Releases

Environment


All Environments

Cause


This is expected behavior in the platform. The reason why the User ID does not pass over is because the Service Portal External Login and SSO Login page are two different products. As a result, integration between the two is not possible. 

Resolution


If this functionality is extremely important to customer's business, connect with ServiceNow Professional Services team as this feature is not currently available out of the box and can only be implemented with customizations. 

 


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