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Global Search Shows "No Title" in the Search Results - Support and Troubleshooting
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  • Global Search Shows "No Title" in the Search Results
KB0683219

Global Search Shows "No Title" in the Search Results


15377 Views Last updated : Jul 7, 2023 public Copy Permalink English (Original)
  • English (Original)
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KB Summary by Now Assist

Issue

Search results through Global Search are showing the results as "No Title" instead of the record's short description.

Release

UI16 with using the new Global Search functionality starting with Jakarta

Cause

The blue bolded text in your search results is called the Title element.

The system uses the first string field that is not the Number field as the Title element. If you have a string field added to your list layout that has empty values, the "No Title" text will display in search results. 

Resolution

There are a few steps to fix this issue.

  1. Take note of what view will be used for the pulling of the data:
    Out of box system property "glide.ui.text_search.view" specifies the List view used for Global Text Search results. This property is set to "text_search" by default. If there is not a Text Search view defined for the table, the Default view will be utilized.
  2. Go to the table in question and put the short description (string field which is generally filled out for testing) right below number in the list:
    We are doing this as the way that global search results are designed is the first string after number as the title.
    1. Log in as an admin
    2. Navigate to the affected table list 'Default' view (i.e. incident.list).
    3. Right-click on any column and Configure > List Layout. Or for List v3, click the cog wheel > Configure > List Layout.
    4. Add in the 'Short description' field to the top of the list so it is the first string field selected for the Title element.

    If you do not want to modify the Default view, create a text_search view for your table instead by following these steps:

    1. Log in as admin and navigate to the affected table (incident.list) in the filter navigator.
    2. Right-click on any of the column name to select Configure > List Layout. Or for List v3, click the cog wheel > Configure > List Layout.
    3. In the List view section, click the view name drop-down menu and select "New".
    4. Name the view exactly "text_search" then click OK.
    5. Verify "text_search" is the selected view and then move "Short Description" to the top of the slush bucket and add any other fields you'd like to see.
    6. Click Save. 
  3. If this doesn't make a difference, there has to be a sys ui list view which is the same as what is being returned.
    1. Go to sys_ui_list.list and ensure that there are no extra views that might be conflicting with the global search.
    2. Examples of this being bad could be an incident view with a parent of incident, associated with no user and, labeled as default view.
If this all looks good, reach out to Technical Support and mention this KB number.

Related Links

Excerpt from our product documentation:

"Global search uses the first string field in the text search view that is not the number field. If there is no matching string field or the contents of the field is empty, the system displays the text "No title" in the session language. For example, in the default incident table view the short description field meets the criteria to be the title."

  • Text search views control format of global search results for tables
  • Global text search displays results dynamically

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