Description
Symptoms
Search results through Global Search are showing the results as "No Title" instead of the record's short description.
Release
Jakarta and later
Environment
UI16 with using the new Global Search functionality starting with Jakarta
Cause
The blue bolded text in your search results is called the Title element.
The system utilizes the first string field that is not the Number field as the Title element. If you have a string field added to your list layout that has empty values, the "No Title" text will display in search results.
Resolution
Out of box system property "glide.ui.text_search.view" specifies the List view used for Global Text Search results. This property is set to "text_search" by default. If there is not a Text Search view defined for the table, the Default view will be utilized.
1) Login as an admin
2) Navigate to the affected table list 'Default' view (i.e. incident.list).
3) Right-click on any column and Configure > List Layout. Or for List v3, click the cog wheel > Configure > List Layout.
4) Add in the 'Short description' field to the top of the list so it is the first string field selected for the Title element.
If you do not want to modify the Default view, create a text_search view for your table instead by following these steps:
Customers may apply the above fix for any field supported by Global Search that is having this issue
Additional Information
Excerpt from our product documentation:
"Global search uses the first string field in the text search view that is not the number field. If there is no matching string field or the contents of the field is empty, the system displays the text "No title" in the session language. For example, in the default incident table view the short description field meets the criteria to be the title."