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When creating a change request from a visual task board the 'type' field is null and read-only - Support and Troubleshooting
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  • When creating a change request from a visual task board the 'type' field is null and read-only
KB0683196

When creating a change request from a visual task board the 'type' field is null and read-only


649 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Creating a Change Request from a Visual task board Freedom board, the 'type' field is blank and read only.

Release


Issue specific to all Jakarta and previous releases.

Cause


This happens because the Change Request wizard that asks you which type of Change Request you want to create does not open from the Visual Task Boards and the customer does not have a default value set for the 'type' field in the dictionary.

Resolution


Modify the write ACL on the change request table for the 'type' field, 'change_request.type'. You can remove the roles restriction currently set to 'nobody' and leave it empty or you can remove the role 'nobody' and add the roles of the users who create change requests.
 
OR
 
Add a default value to the dictionary entry for the 'type' field on the Change Request table.
 
You can use the below URL path to access the ACL:
/sys_security_acl.do?sys_id=2b8845f4cbb00200d71cb9c0c24c9c41&sysparm_view=&sysparm_domain=null&sysparm_domain_scope=null&sysparm_record_row=14&sysparm_record_rows=15&sysparm_record_list=nameSTARTSWITHchange_request%5eORDERBYname
 
If the URL path does not take you to the correct write ACL, you can search for Write ACLs on the Change Request table for the 'type' field or a 'change_request.*' ACL.

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