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Symptoms


Certain text on Service Portal do not translate to the selected language as expected

Release


All releases supporting Service Portal

Cause


Missing entry in sys_translated_text table for the appropriate language and associated sp_instance record for the associated service portal widget instance

Resolution


  • Create a record in sys_translated_text table where the DocumentID equals the sys_id of the sp_instance record (see KB0683179 link below for how to get to this value) on the Service Portal page, Table is sp_instance, and Field Name is Title
  • Customers need to create a record in sys_translated_text for each corresponding language as per the steps below: 
  1. From the Sys_translated_text New record form, click on the magnifying glass for the Document ID field to set the value for this field
  2. Select Instance (sp_instance) as the Table Name for the reference popup dialog 
  3. Again click on the magnifying glass icon for Document ID field in the popup 
  4. Filter the reference popup by SysID= (sysID of the sp_instance) record and save the Document ID selection by clicking OK (see screenshot below)
  5. Set the Field, Language, Table Name, and Value details as needed and save the sys_translated_text record

 

Additional Information


Article Information

Last Updated:2018-04-11 15:05:10
Published:2018-04-11