Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Disabling the Service Portal SSO auto redirection - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Disabling the Service Portal SSO auto redirection
KB0682702

Disabling the Service Portal SSO auto redirection


5454 Views Last updated : Jun 23, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

 

Need to disable the Service Portal SSO auto redirect? The Login widget for Service Portal can be redirected to Single Sign On (SSO) under certain conditions. We'll show you how.

 

The Login widget for Service Portal can be redirected to Single Sign On (SSO) when the following conditions are satisfied:

  1. If the user is not logged in
  2. MultiSSO is enabled using "glide.authenticate.multisso.enabled" system property
  3. Default IDP is set using "glide.authenticate.sso.redirect.idp" system property

 

Release

All

Cause

The automatic SSO redirection is triggered when the following conditions are met:

  • The user is not logged in.
  • The system property glide.authenticate.multisso.enabled is set to true.
  • The property glide.authenticate.sso.redirect.idp is configured with a default identity provider (IDP).

Resolution

To disable auto redirection to SSO in Service Portal and allow users to log in using the portal’s local login widget, follow these steps:

Step 1: Add the bypass_sso option

  1. Navigate to the sp_instance table.
  2. Search for the Login widget instance:
    • Use filter: ID is login-modal
  3. In the Additional Options field (JSON format), add the following:
{
    "bypass_sso": {
         "value": "true",
         "displayValue": "true"
     }
}

This option ensures the login widget bypasses the default SSO redirection logic.


Important Notes

  • The header login link uses the same login widget instance and will also honor this configuration.
  • If you have customized widgets, ensure the bypass_sso logic is respected in the server/client scripts of the login widget.

Related Links

Disable SSO auto redirection for some Portals to local login while still keeping SSO authentication for others

From the Community:
Bypass SSO for VRM Vendor Portal

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.