Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Unable to change the background image in Service Portal branding editor - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Unable to change the background image in Service Portal branding editor
KB0682697

Unable to change the background image in Service Portal branding editor


2020 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Unable to change the background image in Service Portal branding editor

 

Symptoms


The Service Portal branding editor shows a text box instead of a image uploading buttons, Please see the screenshot below

 

Release


ALL

Cause


"Quick start config" field in Portal record (sp_portal table), "hero_background" "sys_id" property not pointing to the first container of the Homepage

Resolution


Please fix the "Quick start config" "hero_background" "sys_id" should point to the first container of the Homepage record,

 

[{

"tagline": {

"table" : "sp_instance",

"sys_id" : "a89f189d4f670340b06f66a01310c7d4",

"field" : "title"

},

"hero_background": {

"table" : "sp_container",

"sys_id" : "be98a8d2cb20020000f8d856634c9c63", -> This should point to the container of the record

"field" : "background_image"

}

}]

 

Service Portal Homepage first container record can be accessed by clicking on the link with "Container 1"

Copy the sys_id of the container record and update the "Quick start config" field in the Portal record to resovle the issue.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.