Issue
Create Change Request UI Actions are not available on an Incident/Task form's right click header menu
Steps to Reproduce:
- Login to effected instance
- Open any incident which is not in closed state
- Click on "Create change request" button.
Cause
- Incident/Task record already has a Change Request attached to it in the task.rfc field on the form
- As a result, and as per the condition in the out of box Create (Normal, Standard, Emergency) Change UI Actions the UI action will not be available on the form
Resolution
- Assuming a new Change Request needs to be created for the record and to have the Change UI Actions available on the form header menu, clear out the existing Change Request value in the task.rfc field and save that value as a Work Note or Additional Comment for future reference and save the form.
- This should allow the Create Change Request UI Actions to be available on the form's header menu (for Task records such as Incident, Problem etc) when you right click on the form.