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Symptoms


The Service Level Agreement (SLA) workflow prior to Jakarta used to go into a state of "Achieved". Post upgrade, we no longer see that state being set. The functionality rather transitioned to using the "Has breached" flag, and the stage of "Breached" is still available.

Cause


Achieved / Breached is not a state supported any longer since the SLA engine 2011.

Resolution


We do not have the stage "Breached", but we do have the fields "Has breached" and "Breach time". The "Has breached" flag is the true|false field that is checked to see if the SLA has breached or not. The [task_sla] records can be breached, but with the SLA stage still "In Progress". 

Please see the Legacy SLA Fields and the current SLA transitions now used in the SLA workflow.


The community thread below also contains useful information on the topic: 

Transitions between stages in SLA management

Article Information

Last Updated:2018-05-29 02:44:47
Published:2018-05-29