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Available for Company, Available for department and Available for group related lists are not appearing on the Catalog Item form even though they are in the "Selected" slush bucket - Support and Troubleshooting
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  • Available for Company, Available for department and Available for group related lists are not appearing on the Catalog Item form even though they are in the "Selected" slush bucket
KB0681679

Available for Company, Available for department and Available for group related lists are not appearing on the Catalog Item form even though they are in the "Selected" slush bucket


1252 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

Available for Company, Available for department and Available for group related lists are not appearing on the Catalog Item form even though they are in the "Selected" slush bucket. 

Release

London+

Cause

There is a OOTB system property called 'glide.sc.use_user_criteria'. with the Default value: true. 

nav_to.do?uri=sys_properties.do?sys_id=f3d65982c3202100c8b837659bba8fe3 

But, Entitlements are not honored if set to true. That's the reason we need to set this property to False in order to display the Available for options on the form. 

The value of this system property governs an onLoad Client Script called 'Hide User Criteria Related Lists' which is hiding the Related List when the form loads. 

Resolution

1. Update 'glide.sc.use_user_criteria' the system property value to 'False'

Additional Information

After setting above System Property to 'false', fields like 'Available for Company', 'Available for department' and 'Available for group' appear on the form as expected. 


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