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Why searching in the Service Portal search box user see double entries? - Support and Troubleshooting
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  • Why searching in the Service Portal search box user see double entries?
KB0681363

Why searching in the Service Portal search box user see double entries?


731 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Issue Summary:

When user search in the search box, for example on ‘functional account’, they see double entries. Due to this, multiple results  are shown in Service Portal but when clicked user cannot view the search result.

 

Cause:

For the Service Portal record /sp, it happens when multiple search sources are defined on the same table (e.g "sc_cat_item") with over lapping conditions.
 
For example: 
- - - 
Search Source 1 : Active = True AND ( Catalog Contains "Global Catalog" OR "Local Catalog" OR "RD Catalog" OR "User Device Catalog")
Search Source 2 : Active = True AND ( Catalog Contains "Global Catalog")
Search Source 3 : Active = True AND ( Catalog Contains "Local Catalog")
Search Source 4 : Active = True AND ( Catalog Contains "User Device Catalog")
- - - 
 
As you can see Search source 1 is nothing but the grouped version of the search sources 2 3 and 4.

For example the when user searches for "functional account", this result is returned by both search source 1 and search source 4.
 
 
Solution:

In such scenarios, solution is to:

  • Delete the search sources 2,3,4
  • For search source 1, in the "Type Ahead" tab, change the page value from "index" to "sc_cat_item".

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