Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Updates in an update set no longer uses sys_updated_on time of an update to determine changes - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Updates in an update set no longer uses sys_updated_on time of an update to determine changes
KB0680110

Updates in an update set no longer uses sys_updated_on time of an update to determine changes


477 Views Last updated : May 4, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

  • Previewing an update set displays a message in preview problems indicating that there is a local change which is newer than the change from the remote update set
  • Reviewing the actual local update on the target shows that the changes are actually older than what is being brought over from the source based off of the sys_updated_on field


Cause

The behavior for this is expected as there has been a change in the update set engine where we are no longer using the time of an update to determine whether or not changes have been made. The logic used now is more in line with source control practices. Any update set that is being brought over from a source instance to a target instance will always produce a collision error if there changes were made to the same record in both target and source instances regardless if the changes on the target is newer or older than the updates on the source. The engine now treats this as a merge conflict similar to what is seen with source control.

Resolution

The user, administrator, or developer needs to determine which changes to keep and then apply these as needed.



The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.