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Notifications sent when "Record inserted or updated" are not triggered if the SLA associated fails - Support and Troubleshooting
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KB0679508

Notifications sent when "Record inserted or updated" are not triggered if the SLA associated fails


1610 Views Last updated : Apr 26, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Notifications sent when "Record inserted or updated" are not triggered if the SLA associated fails

Problem

On some cases, tables with SLA generation, the notification trigger by the engine on tables insert or update, are not triggered.

Symptoms

This problem is recognized when:

  • The table is an extension to task (e.g. incident, change_management, etc) and has SLAs definitions created.
  • Notifications generated by tables Update or Insert are not triggered.
  • If the notification sent when is set to event is fired, they are triggered correctly.
  • On the node localhost, when the business rule logging is enabled, script execution of some engines (before engines or after engines) does not appear on the table insert/update.
  • If you stop the Business rule Run SLAs, the problem no longer happens.
Cause

Some SLA processing could stop the execution of the scripts executed after the Run SLAs business rule. If the execution is stopped, the notifications are not triggered as expected.

Resolution

If facing this behavior, either:

  • Modify the notification to execute when a event is fired and select the <table>.inserted or <table>.updated accordingly
  • Stop any problematic SLA from executing.

 

 


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