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Description


After upgrading to Jakarta, on Service Portal header menu items which have zero count do not appear.

In general, when a user login to service portal, approvals and requests are shown in the header menu with the count of items, though it has zero count. However, in Jakarta release, when the count is zero, the menu item will not be shown on the portal. you can reproduce the issue with below steps:

Steps to reproduce the issue

  1. Log on to an out-of-box Jakarta instance
  2. Impersonate a user who doesn't have any approval for example "ITIL User"
  3. Navigate to service portal "/sp"
  4. Observe the Approvals menu, it will not be visible to user

Cause


Due to an enhancement in Jakarta release, the menu option is hidden when the record count is zero. 

Solution


If you want to override this enhancement, and you want to show the menu item to the user, even when the count is zero, perform this work-around.

  1. Open the "Header Menu" widget (/nav_to.do?uri=sp_widget.do?sys_id=5ef595c1cb12020000f8d856634c9c6e) and update line 41
    • Replace:
      • if (item.items || (item.scriptedItems && item.scriptedItems.count != 0))
    • with
      • if (item.items || (item.scriptedItems && item.scriptedItems.count >= 0)) 

 

Article Information

Last Updated:2019-05-21 11:51:20
Published:2019-01-31