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How to translate the standard chat response that is added when agent joins or leave the chat conversation



Overview


When an agent or the user leaves or enters the chat session, the messages are not translated. When a french user enters the chat support conversation, fields and messages should be translated in french.
 
For example, leaving chat session message <User> has left the support session does not have out of the box French translation.

 

How To


  1. Install I18N French Language
  2. Configure the Support Chat queue: 
  3. Start support chat session.
  4. End the session.
  5. Notice the leaving chat message is not translated in French.

 

Cause


The issue is that the translations for the following keys were not included: 

{0} has closed the support session 
{0} has left the support session
{0} has rejoined the support session 
Transferring back to the {0} queue 
Escalating to the {0} queue 

 

Solution


To resolve this issue, please create sys_ui_message records using the below information as keys, providing your own translations. 

As an example, create the following record to make sure the first key above is translated: 

sys_ui_message table 
Clé: {0} has closed the support session 
Langue: French 
Message: {0} <translation of "has closed the support session"> 

Article Information

Last Updated:2018-02-09 06:50:45
Published:2018-02-09