Issue
Multifactor Authentication stops accepting Google and Microsoft Authenticator code.
Symptoms
For IOS device
Steps to follow:
- Go the phone Settings
- Scroll down and click on General
- Scroll down and click on Date & Time
- Select Set Automatically to true.
- Close and reopen Google Authenticator / Microsoft Authenticator app.
For ANDROID device
Steps to follow:
- Go the main menu of the Google / Microsoft Authenticator app.
- Click on the three dots on the top right hand side.
- Click on Settings.
- Select Time correction for codes.
- Click Sync now.
- The message displayed will confirm if the time has been synchronised or if it was already correct.
Release
All releases
Cause
The most probable cause is that the time on the device is not synchronised.
Resolution
If the message displayed states that the time is already correct:
- Go back to the main page of the Google Authenticator / Microsoft Authenticator app.
- Click and hold on the code shown on the screen.
- Click delete icon and re install.