Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
@Mention functionality not working on journal fields when removing all available fields from activity stream via configuration filter - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • @Mention functionality not working on journal fields when removing all available fields from activity stream via configuration filter
KB0676148

@Mention functionality not working on journal fields when removing all available fields from activity stream via configuration filter


1619 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

@Mention functionality not working on journal fields when removing all available fields from activity stream via configuration filter

 

 

Problem


This issue with the @mention functionality can be reproduced with the steps below:

Steps to reproduce the issue

 
1. Log on to any out of the box Jakarta instance
2. Impersonate any user, for example "System Administrator"
2. Navigate to "Incident=>Open"
3. Open one of the incident record
4. Go to Notes section
5. Click on Activity filter
6. Uncheck "All" option
7. Reload the form
8. Try using the @mention functionality in one of the journal fields ("comments"/"work notes")

 

Cause


When unchecking the 'All' option in the activity configuration filter, and reloading the form, this is pushed back to the legacy UI15 mode. As per the Activity streams in UI16 and UI15 documentation, the @mention functionality will not work on UI15, it supported only on UI16.


However, In the Kingston release, we see the above issue is not reproducible. Even if all fields are filtered out on Configuration filter, the form stays in UI16 mode and the @mention function works fine as expected.

 

Workaround


On Jakarta, the workaround is to make sure the journal fields (comments, work_notes) are always selected on the activity filter.

 

Solution


Upgrade to Kingston release to resolve the issue permenantly.

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.