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Report export shows message "Too much data to export" - Support and Troubleshooting
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  • Report export shows message "Too much data to export"
KB0675016

Report export shows message "Too much data to export"


855 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

When trying to export this report to PDF and then opening the file the following message is shown instead of the data: 

"Too much data to export"

Cause

Reports are generated by the Highcharts reporting engine (via JSON). When you attempt to save it as a png or jpg, this request goes out to an export server, which takes the input data of the report and creates the png or jpg. However, there is a limit to how much data can be sent to the export server for processing into a png or jpg, and your report's data is exceeding this limit. As such, you are seeing the "too much data" message as expected. 

Resolution

The only workaround remains to decrease the number of data points in the report by filtering. 
Else you could take a print screen or screen capture of your report. 

Questions to ask when building reports: 
What is the relevancy of the data you try to show, what will be done with the data, is it human readable? 

For example when making a report stating incidents created per week, does your weekly report really need to be over the full history or just on the last 3 months?.  Also then showing the stack on "other" it may be limiting the visibility on the other bars and add a lot of data you would not foresee need.

Related Links

There is a 64KB limit on the input to a report. This limit is considered per input. So it's probably not triggering on the jpg.
We also have a 1MB limit on the generated JSON and that is likely the issue if you thit this issue on the instance.

The 64KB limit was set because the Rhino engine doesn't deal with bigger inputs, and 1MB is chosen because AVP export server doesn't accept bigger payloads.


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