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Workflow Engine: Slowness in Workflow Activity Execution

 

Problem
Users have reported slowness in workflow activity execution. The issue is not reproducible on demand and it is not limited to a specific workflow activity.

 

 

Symptoms
The symptoms below are examples, but are not limited as this behaviour can impact any workflow activity:
  • Workflow Timers taking longer to execute than expected, even though the scheduler is clear
  • Sub Workflows are completed but Sub Flow activity not continuing to next activity
  • Begin activities not transitioning to next activity

  

Cause

The cause for this issue would be due to custom business rules on the following Workflow Tables. For example, the business rules may exist on (but are not limited to) the following workflow tables:

  • Workflow Context [wf_context]
  • Workflow Executing [wf_executing]
  • Workflow Activity [wf_activity]
  • Workflow Transition [wf_transition]
  • Workflow Version [wf_workflow_version]

Resolution

Since the tables above have base-system business rules, records and java script execution that are used as part of the Workflow Engine, ServiceNow would recommend to de-activate any custom business rules on the Workflow tables.

Warning: Please ensure that any of the steps taken in the resolution is executed on a non-production instance that is a copy of production for testing purposes, before any modification is made on production instances.

 

Article Information

Last Updated:2018-01-09 06:43:18
Published:2018-01-09