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Unable to use custom scoped workflow activity in scoped workflow - Support and Troubleshooting
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  • Unable to use custom scoped workflow activity in scoped workflow
KB0661900

Unable to use custom scoped workflow activity in scoped workflow


1680 Views Last updated : Sep 21, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Unable to use custom scoped workflow activity in scoped workflow 

 

Problem
Users have reported an issue where they are unable to use custom scoped workflow activities in scoped workflows, which are designed to run on scoped applications.

  

Symptoms
  • User receives an error Invalid Activity Definitions when they hover over a Workflow activity that has executed on a running workflow
  • Custom activity is highlighted as red on the running Workflow with the result returned as error.

 

Cause

This issue occurs when users are creating custom workflow activities within a Scoped Application outside of the Activity Designer.

In this case, the user has manually created a Workflow Activity Definition directly via the wf_activity_definition table, under a Scoped Application.

As the core activities are looking within the Global Scope, the error Invalid Activity Definitions is displayed.

 

Resolution
It is recommended to use the Activity Designer to create custom activities, as it is able to handle the logic of creating custom activities inside scoped applications.

For more information on using the Activity Designer, please review the documentation below:

https://docs.servicenow.com/csh?topicname=c_WorkflowActivityDesigner.html&version=latest

Therefore to conclude, the behaviour that the users are experiencing is by design. Custom activity development is traditionally licensed under Orchestration. Orchestration provides support for application scoping for custom activities using the Activity Designer.

WARNING: Please note that the Activity Designer comes with the Orchestration plugin, which is a paid plugin that has separate subscription fees. Please ensure that you review the documentation above and consult your Account Manager or Territory Manager for more information.


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