Issue
Incoming email messages watermark are ignored if glide.email.watermark.parse_restrictive is true for incoming emails, and the watermarks are missing the randomize <watermark>_xxxxx part.
- You have recently upgraded to an instance version that supports randomized watermarks
- You have activated the Random Watermark Support plugin.
- The sys_properties record glide.email.watermark.parse_restrictive value is true
- The emails watermarks are not recognized, and they look like Ref:MSG0000001 (instead of Ref:MSG000001_asdrewtwer)
Cause
When the Random Watermark Support plugin is active and enabled, the watermark format changes to add a 20 character random string to the watermarks, to make them unique.
Note: glide.email.watermark.parse_restrictive is not related to the target record or match with watermark table. The watermark coming from inbound email and the one present in sys_watermark record should be the same in order to recognize the target record.
Resolution
Determine a watermark transition period during which the system must recognize both randomized and non-randomized watermarks. This transition period is the time needed for the system to process incoming email replies containing non-randomized watermarks.
During this time, set glide.email.watermark.parse_restrictive to false
Note: With sys_properties record glide.email.watermark.parse_restrictive value of false, the system would recognize both randomized and non-randomized watermarks |
Related Links
https://docs.servicenow.com/csh?topicname=c_WorkingWithWatermarks.html&version=latest