142 views

Non randomized watermarks are ignored when glide.email.watermark.parse_restrictive is true for incoming emails

Problem

Incoming email messages watermark are ignored if glide.email.watermark.parse_restrictive is true for incoming emails and the watermarks is missing the ramdomize <watermark>_xxxxx part.

Symptoms

You can recognize this problem because

  • You have recently upgraded to a instance version that supports ramdomized watermarks
  • You have activated the Random Watermark Support plugin.
  • The sys_properties record glide.email.watermark.parse_restrictive value is true
  • The emails watermarks are not recognised and they look like Ref:MSG0000001 (instead of Ref:MSG000001_asdrewtwer)
Cause

When the Random Watermark Support plugin is active and enabled, the watermark format changes to add a 20 character random string to the watermarks, to make them unique.

Resolution

Determine a watermark transition period during which the system must recognize both randomized and non-randomized watermarks. This transition period is the time needed for the system to process incoming email replies containing non-randomized watermarks.

During this time, set glide.email.watermark.parse_restrictive to false

 
Note: With sys_properties record glide.email.watermark.parse_restrictive value of false, the system would recognize both randomized and non-randomized watermarks

 

 

Article Information

Last Updated:2018-07-31 10:56:40
Published:2018-07-31