Issue
Why duplicate Connect chat mini window appears for user?
Overview
Connect mini window for same task record appears many times for a user. For example, mini window is appears for incident record INC000001 for more than once.
How To
- Log on to affected instance
- Impersonate affected user
- Open the connect mini window via clicking on the connect overlay at the top right corner
Chat window appears multiple times for the same task record.
Observations:
- When a user follows a task record, a live_group_profile record would be created for it.
- When another user follows the same task record, existing live_group_profile record should be updated instead of creating a new one.
Cause
Duplicate live_group_profile records causing multiple chat mini window appear for the users who are all following the task record.
Solution
Delete the duplicate live_group_profile record of the task record and it should resolve the issue with multiple connect mini window.
On out of the box, duplicate live_group_profile records never created, most of the time, it is caused by the customization. When you run into similar issue, please review the custom business rules which creates a live_group_profile record.