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Service Portal Record Producer throws "400 Bad Request" error and form gets stuck on submitting - Support and Troubleshooting
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KB0656139

Service Portal Record Producer throws "400 Bad Request" error and form gets stuck on submitting


12634 Views Last updated : May 19, 2023 public Copy Permalink English (Original)
  • English (Original)
  • Japanese
KB Summary by Now Assist

Issue

This article describes an issue customers can run into when using a record producer on the Service Portal.

Error seen when submitting a record producer

After pressing Submit, the record producer gets stuck on Submitting... See below:

The Console shows a 400 bad request error, along with an error message for the object. See below:

Cause

This issue is seen when any of the variables in the item is set to Mandatory through the variable record, instead of using a UI Policy or the users do not pass the READ ACLs on item_option_new table.

 

In Jakarta, the SC Catalog Item widget will use the GlideRecordSecure API, which will require modification or ACL creation if you have any variables set directly to 'mandatory'.

OR

In the newer versions like London & Madrid, these errors might be caused by using a custom widget which uses deprecated code.

Resolution

To solve this issue, try one of the following things:

  • Uncheck the Mandatory checkbox on all variables on the item, and use a UI Policy instead to make the variables mandatory. See: Create a UI Policy
  • Review READ ACLs on the item_option_new table, and confirm that the users can pass the ACLs. To test, you can create an open-ended READ ACL for all the fields in item_option_new by using a wildcard. See below:

 

OR 

Revert to Out of Box "SC Catalog Item" widget

Related Links

For issues related to using REST API on record producers, review:

  • How to submit a catalog item using REST API
  • Service Catalog API

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