Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
How to address an unavailable Edge Encryption Proxy throwing the error 'java connection failed' - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • How to address an unavailable Edge Encryption Proxy throwing the error 'java connection failed'
KB0647587

How to address an unavailable Edge Encryption Proxy throwing the error 'java connection failed'


610 Views Last updated : Dec 5, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

How to address an unavailable Edge Encryption Proxy throwing the error 'java connection failed'


Problem
EEP are connecting via an Enterprise Proxy, this may cause an issue if the Enterprise Proxy is intermittently unreachable.


Symptoms
Applications show time out errors, but the EEP does not show any errors until restarted.
  • Instance logs will show the Java connection timeout
  • Users will experience the Edge Encryption Proxy as unavailable


Cause
The error occurs when the further connection to an intermediate proxy can not be established. Without connectivity the encryption proxy cannot reach the instance.



Resolution
Diagnose the intermediate proxy and restart it if necessary. This has to be 100% reachable and running.
Following that, the Edge Encryption Proxy Service will need to be restarted. Error messages, if present, will not appear before a few minutes that the service has been running.



The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.