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Subscribable notifications with affected and event field empty will trigger for all subscribed users - Support and Troubleshooting
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KB0635959

Subscribable notifications with affected and event field empty will trigger for all subscribed users


3963 Views Last updated : Apr 8, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Subscribable notifications with affected and event field empty will trigger for all subscribed users



Problem


Attempts to subscribe to a notification and receive it without having to subscribe to a CMDB Configuration Item (CI) are unsuccessful. Everyone subscribed to the notification will receive it every time it triggers. In some cases, it will stop working.

Symptoms


You could experience the need to validate your subscribable notifications if:

  • You have upgraded to the latest product version.
  • You are no longer using the legacy subscribable engine.
  • Users stop receiving the notifications they are subscribed to.

Cause


After an upgrade, several forms related to subscription will be modified or updated.

Resolution


To receive a subscribable notification without having to relate a CI:

  1. Go to sys_properties_list.do and set the glide.notification.use_legacy_subscription system property value to false.

  2. Navigate to System Notification > Email > Notifications and open the notification.

  3. Select the Subscribable checkbox.

  4. Leave the Affected field on the event field empty.

  5. Leave the Item table field empty.

  6. Click Update.

  7. On the user preferences, subscribe to the notification and it will not ask you to add a Configuration Item (CI).

    Subscribable notifications with affected and event field empty will trigger for all subscribed users for the notification

Note: Every time the notification triggers, all the subscribed users will receive the notification as well

 

When adding a subscribable notification, it will not ask for a CI

 


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