Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Incoming email body (html) and body text depends on the content type - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Incoming email body (html) and body text depends on the content type
KB0635957

Incoming email body (html) and body text depends on the content type


8354 Views Last updated : Jul 22, 2025 public Copy Permalink English (Original)
  • English (Original)
  • Japanese
KB Summary by Now Assist

Issue

Some clients allow the creation of different HTML and text part on the emails or auto-generate the missing HTML or text part of the email when it is sent.

Symptoms:
When reviewing the sys_email records, in some cases the HTML body when previewed contains different information than the body text field.

Cause

Some clients allow the creation of different HTML and text part on the emails. When received, incoming emails are treated differently depending on the content type.

Given the HTML content, most clients will automatically create a text version. In that case, each HTML and text version is extracted from the incoming email and there is no need to generate either content. However, if the HTML content exists and the text version is not available, it is generated automatically. Similarly, if only the text content exists and the HTML version is not available, it is generated automatically. 

 

Incoming email content type

Email body_html

Email body_text

Reason

text/plain

Generated

Extracted from email if available

Because the HTML text is not available, it is generated based on the body_text

text/html

Extracted from email if available

Generated

Because the TEXT version is not available, it is generated by stripping the HTML tags

Multipart

Extracted from email if available or generated

Extracted from email if available or generated

The available types text/plain or text/html are extracted on the multipart section

 

content type on the email

Resolution

If either the body text or body (HTML) in the email do not match, validate the email content type to understand the source of the differences. If the text was auto-generated, the source is on the necessary conversion. However, if the incoming emails is multipart, validate whether the client sending the emails is causing the differences because the information is extracted on the email itself.

If you depend on the email body (HTML), ensure that clients are sending the text/html content correctly. If you depend on the body text, ensure that clients are sending the text/plain content on the emails.

 

Note: Validate whether the differences come from automatic systems integrating by email.

 

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.