Issue
Incoming approval emails with subject containing "requires your approval/rejection" are rejected
If the subject text of an incoming email to be approved contains "requires your approval/rejection", the email inbound action for approval rejects the associated approval record.
Note: Inbound emails for approval needs to have a matching watermark in the email body or subject
Release
All
Cause
If a request for approval is sent and the notification contains "requires your approval/rejection" in the subject text, when the person replies, the subject containing "rejection" matches a search for "reject", which causes the approval record to be rejected.
Note: Email body has precedence to the email subject on the approval inbound action
Resolution
Subject contains | Body contains | Approval result | |
Email 1 | approve | approved | |
Email 2 | reject | rejected | |
Email 3 | approved | ignored | |
Email 4 | state: approve | approved | |
Email 5 | state: reject | rejected | |
Email 6 | approve | state: reject | rejected |
Email 7 | reject | state: approve | approved |
Email 8 | reject | approved | rejected |
Email 9 | Approved | ignored |
The simplest solution is to change the outbound email notification to avoid subjects containing the words "approved" or "reject".
To fix the response email to approve the record, put "state: approve" in the body, retaining the watermark from the approval email, or replace the subject with either approve or reject (case sensitive).
Note: Adding "Approved" in the email response body is not enough. The body text needs to say "state: approve" or "state: reject" or contain either approve or reject in the subject. A watermark in the incoming email is ALWAYS required for approval records.