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Attachments added by email client/quick messages are not recorded in the tasks



Problem


Attachments added by the quick message option are not recorded in the task (for example, the incident table).

attachments are not added to the incident

Symptoms


When an attachment is added by the quick message and sent to a customer from an incident, the attachment is not saved in the task itself. 

Cause


Email client attachments are added to the email that is sent. The email client creates a new record on the sys_email table and adds the attachment. They are not attached to the task.

Resolution


The email client was created to independently send emails and its attachments. If you also need a copy of the attachments into the parent task (for example, incident), you would need to customize the email table (sys_email) so a copy is also added to the relevant target records.

 you need to create scripts to add the attachments into the target record

 

Article Information

Last Updated:2018-01-03 12:26:52
Published:2018-01-03