716 views

Description

Service Portal - Date/Time variable does not show the correct value if the record is accessed through service portal after submission.

Steps to Reproduce

 

  1. Activate the Service Portal plugin.
  2. As a user with elevated privileges, navigate to Settings and change the time zone to US/Central.
  3. Navigate to Service Catalog > Maintain ItemsSample item.
  4. Activate the catalog item.
  5. Click Try it. Notice the field Date/Time shows the current time in US/Central.
  6. Set the value in this field and submit the request. The RITM Variable editor shows the same time set before submitting the record for the Date/Time variable.
  7. Access the same record in Service Portal: 
    /sp?id=form&table=sc_req_item&sys_id=41bdcafbdb423200f2fff71fbf961948&view=sp. Make sure that the page ID is form.

The variable editor Date/Time field should show the same time in the Service Portal as seen in RITM record outside of the Service Portal. Instead, the variable value shows a time that is five hours ahead than expected.

The issue is not related to the Date/Time picker but with how the value shows up after submitting for the Date/Time variable.

Workaround

This issue is under review. If you are able to upgrade, check the Fixed In field below to determine the versions that have a permanent fix. You can also subscribe to this known error article (click Subscribe button at the top of the article) to receive notifications when more information is available about this issue.


Related Problem: PRB934309

Seen In

There is no data to report.

Fixed In

Istanbul Patch 9
Jakarta Patch 2
Kingston

Associated Community Threads

There is no data to report.

Article Information

Last Updated:2018-08-22 15:39:02
Published:2017-08-18