Issue
Symptoms
After enabling Multi-SSO, some SSO validations might fail if the Multi-SSO installation scripts do not execute first.
There are some exception cases where some SAML* installation exits remain active (incorrectly) after the Multi-SSO plugin is installed, for example, if SAML is already active at the time you activated Multiple Single Sign-On and if you already customized the SAML installation exits.
This could cause the logs to show the following errors:
WARNING *** WARNING *** Evaluator: org.mozilla.javascript.EcmaError: Cannot convert null to an object. |
Cause
Multi-SSO is replacing the previous SAML installation exits; however, in some cases, the previous SAML installation exits are not disabled.
Resolution
To resolve the problem, if Multi-SSO is installed correctly, validate that the following installation exits have Active set to False:
- SAML2Logout
- SAML2Logout_update1
- SAML2SingleSignon
- SAML2SingleSignon_update1