Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
SOAP traffic sending a large header to the instance generates HTTP 400 and a possible error message "An existing connection was forcibly closed by the remote host" - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • SOAP traffic sending a large header to the instance generates HTTP 400 and a possible error message "An existing connection was forcibly closed by the remote host"
KB0623293

SOAP traffic sending a large header to the instance generates HTTP 400 and a possible error message "An existing connection was forcibly closed by the remote host"


1930 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

SOAP traffic sending a large header to the instance generates HTTP 400 and a possible error message "An existing connection was forcibly closed by the remote host"

Problem

SOAP traffic to the instance generates HTTP 400 and it may generate an error message "An existing connection was forcibly closed by the remote host".

If a SOAP client need to send a large message, the message gets split into multiple packages. The instance will return errors if there is no session on the headers (persisting HTTP sessions) or an authorization header.

For more information on persistence HTTP, see the product documentation topic Persisting an HTTP session across all SOAP calls.

Symptoms

SOAP messages to the instance will receive a HTTP 400 response from the server. Reviewing the SOAP message sent, the header will be either very large or does not contain the JSESSIONID cookie.

Cause

Missing or incorrectly implementing a persisting HTTP sessions (for example, just appending the cookies) can cause the header to grow and cause an HTTP 400 error if the JSESSION is not added or the header is too big.

Resolution

Get the JSESSIONID from the cookies, then reuse that JSESSIONID in subsequent calls. Only JSESSIONID is required to achieve session reuse. There is no need to include other cookies like glide_session_store, so there is no need to append the other cookie information.

Cookies to add


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

Attachments

Attachments

  • 2017-06-21_0824_a.png

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.