Application navigator (left nav) does not load (is blank/continuously loading) in UI16 when using IE (Internet Explorer).

HTTP response code 202 is being returned by the server when requesting the application navigator content (GET request to /api/now/ui/navigator/favorites).

GlideRequestManager will send a 202 Accepted response to any subsequent request received after one of the following scenarios are met:

  1. 3 transactions for that session are pending. This number of transactions can be controlled by the com.glide.request.max_waiters system property.
  2. A transaction has been running for longer than 30 seconds. This period can be controlled by the com.glide.request.max_run_time_ms system property.

It has been discovered that there are scenarios where the GET request to /api/now/ui/navigator/favorites to retrieve the application navigator content responded with 202 Accepted, and the application navigator does not handle this response type gracefully, remaining blank.


Steps to Reproduce

The steps to reproduce are varied and non-specific.  It is often difficult to reproduce this unless happening in an instance. Generally, all one must do is log into an affected system to see the issue.


Create the following system property:


Related Problem: PRB704793

Seen In

Geneva Patch 7
Helsinki Patch 1
Helsinki Patch 2
Helsinki Patch 3
Helsinki Patch 3 Hot Fix 7
Helsinki Patch 4
Helsinki Patch 5
Helsinki Patch 6 Hot Fix 1

Fixed In


Associated Community Threads

There is no data to report.

Article Information

Last Updated:2018-03-07 17:51:11