Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Service Catalog - Troubleshooting the error "ReferenceError: guideNext is not defined" - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Service Catalog - Troubleshooting the error "ReferenceError: guideNext is not defined"
KB0622050

Service Catalog - Troubleshooting the error "ReferenceError: guideNext is not defined"


806 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Service Catalog - Troubleshooting the error "ReferenceError: guideNext is not defined"

Problem

In the Service Catalog Order Guide, the user receives the following error in the Google Chrome or Mozilla Firefox browser developer tools when they click the Next UI button: ReferenceError: guideNext is not defined

This happens when an instance is upgraded from Eureka (or earlier) to Fuji or later releases.

Symptoms

The following symptoms are seen on the Service Catalog when replicating the issue:

  • Order Guide not going to the Choose Options page after clicking Next
  • Order Guide showing the Next button instead of the Choose Options page
  • ReferenceError: guideNext is not defined shown in the Developer Tools on Google Chrome and Mozilla Firefox
Cause

The cause of the issue is with the UI page com.glideapp.servicecatalog_cat_item_guide_view being modified in Eureka, or a previous release.

When the instance is upgraded to Fuji, or later, release, this causes the code within the UI page above to be skipped during the upgrade to maintain the customization. However this causes the updated code to not be applied to the UI page and therefore causes the error to be thrown.

Resolution

 

Warning: The following change involves modifying the functionality of the Order Guide checkout process. Therefore as a caution, please ensure that the resolution is applied to a sub-production instance and ensure that testing is in progress before applying the change to a production instance.

 

 

 

To provide resolution to the problem, the UI page com.glideapp.servicecatalog_cat_item_guide_view needs to be reverted to Base System. To do this, please perform the following step :

  1. On the ServiceNow instance, find the navigation filter, and select System UI > UI Pages 
  2. Search for the UI page name com.glideapp.servicecatalog_cat_item_guide_view
  3. Open up the UI page com.glideapp.servicecatalog_cat_item_guide_view
  4. Ensure that the Versions related list is shown. If not, right-click the header, select Configure > Related List, then select Versions and click Save.
  5. On the Versions Related List, click the record where the source contains the upgraded instance version
  6. On the Version record, select Related Links > Revert to this version
  7. Click OK
 

The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.