Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Possible causes for interactive filters loading slowly on forms - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Possible causes for interactive filters loading slowly on forms
KB0621442

Possible causes for interactive filters loading slowly on forms


1563 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Possible causes for interactive filters loading slowly on forms

Problem Symptoms
Interactive filters load slowly or cause slowness when you select a value.

  

Cause
The issue may be caused by too many possible values, or by referencing too many tables.

 


Resolution

Too many possible values


When you create the interactive filter, note the number of records that match the conditions. For example, in the following configuration there are greater than 20,000 possible values:

In this scenario, ensure that there are fewer than 10,000 possible values. Apply additional filter conditions to reduce the total number of matching values.

If your conditions are particularly complex, consider creating a script include function that returns the correct set of records and create a condition that uses the result of that function.

Too many references


When a user selects a value in an interactive filter, all widgets on the dashboard receive notifications about the change in the filter. The more references there are defined in the filter, the slower the response.

When you create an interactive filter on a field used by extended tables such as Assigned to on Incident or Problem, create the filter on the parent table, such as Task. By creating the filter on the parent table, a single reference can be used in place of multiple references to the child tables.
This behaviour has been fixed in the Istanbul release. Adding a filter condition on the extended table is equivalent to adding the filter condition on the parent table in Istanbul and later. 
 

The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.