Notifications

497 views

Description

At times, the security_admin role is lost immediately after elevating privileges using the 'Elevate Privilege' popup dialog.

This issue happens inconsistently and hard to reproduce.

Steps to Reproduce

  1. Log in as a user with the security_admin role.
  2. In the upper right, click the arrow next to the user name and select Elevate Roles.



  3. Select the security_admin option..
  4. Click OK.
  5. Perform steps 2-4 above from any existing ACL form record.
    Note that the security_admin role is elevated that one time. The Elevate Privilege popup, however, still shows the security_admin role as cleared. 
  6. Move away from the ACL form record, for example, go to ACL list.
    Note that the security_admin role is immediately revoked. Verify by checking that the New button is absent in the ACL list.

Workaround

There are two workaround options:

  • Click on the padlock one more time and re-elevate again
  • Switch to UI16

Related Problem: PRB632217

Seen In

Eureka Patch 5
Fuji Patch 13 Hot Fix 1
Fuji Patch 3
Geneva Patch 0 Hot Fix 1
Geneva Patch 1
Geneva Patch 3
Geneva Patch 3 Hot Fix 2
Geneva Patch 4
Geneva Patch 4 Hot Fix 2
Geneva Patch 5
Geneva Patch 6
Geneva Patch 6 Hot Fix 2
Geneva Patch 7
Geneva Patch 8
Geneva Patch 8 Hot Fix 1
Geneva Patch 9
Helsinki
Helsinki Patch 0 Hot Fix 1
Helsinki Patch 1
Helsinki Patch 2
Helsinki Patch 3
Helsinki Patch 3 Hot Fix 2
Helsinki Patch 3 Hot Fix 7
Helsinki Patch 4
Helsinki Patch 5

Associated Community Threads

There is no data to report.

Article Information

Last Updated:2017-05-15 14:02:12
Published:2016-10-21