264 views

Description

On a record producer outside of CMS, if you have a variable that contains a UI Macro that is populated with the following:
<?xml version="1.0" encoding="utf-8" ?>
<j:jelly trim="false" xmlns:j="jelly:core" xmlns:g="glide" xmlns:j2="null" xmlns:g2="null">
<iframe id="knowledgeFrame" width="100%" onload="resizeIframe(this)" frameborder="0" src='kb_find.do' ></iframe>
</j:jelly>

A Knowledge Search iFrame is created, and works as expected. However, inside CMS, when using that record producer, the iFrame block is there but the Search field does not display.

Steps to Reproduce

In Eureka:

  1. Create a new UI Macro: test_kb_ui_macro.

  2. Use the following XML code:

    <j:jelly trim="false" xmlns:j="jelly:core" xmlns:g="glide" xmlns:j2="null" xmlns:g2="null">
    <iframe id="knowledgeFrame" width="100%" onload="resizeIframe(this)" frameborder="0" src='kb_find.do'>
    </iframe>
    </j:jelly>

  3. Navigate to Service Catalog > Record Producers.

  4. Go to Something Broken.

  5. Create a new Variable:

    Order: 500
    Type: Macro with Label
    Macro: test_kb_ui_macro.

  6. Click Save and click Try It on the record producer.

    The record producer works as expected with the Search field displayed.

  7. Go to /ess/create_incident.do.

    Note that the iFrame block is there but the Search field is missing.

 

Workaround

There is no known workaround for this issue. To receive notifications when more information is available, subscribe to this Known Error article by clicking the Subscribe button at the top right of the article. If you are able to upgrade, review the Fixed In field to determine whether any versions have a permanent fix.


Related Problem: PRB621276

Seen In

Eureka Patch 3 Hot Fix 1

Associated Community Threads

There is no data to report.

Article Information

Last Updated:2016-11-28 10:08:39
Published:2016-10-18