Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Accessing a Public table through SOAP fails - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Accessing a Public table through SOAP fails
KB0597588

Accessing a Public table through SOAP fails


1357 Views Last updated : Jan 28, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Error when retrieving Public table data using SOAP

 

Problem
Unable to retrieve a record from a table using SOAP web service.

 

Symptoms

Public table is queried (the sys_public table has an entry for this table and the value is true) and the following error is returned to the SOAP client application: 

com.glide.processors.soap.SOAPProcessingException: insufficient rights to read <table_name> <sys_id></faultstring>
<detail>com.glide.processors.soap.SOAPProcessingException: insufficient rights to read <table_name> <sys_id>
at com.glide.processors.soap.command.Get.process(Get.java:54)
at com.glide.processors.soap.SOAPProcessorThread.doCommand(SOAPProcessorThread.java:305)
at com.glide.processors.soap.SOAPProcessorThread.doCommand(SOAPProcessorThread.java:294)
at com.glide.processors.soap.SOAPProcessorThread.processStandardWebService(SOAPProcessorThread.java:226)
at com.glide.processors.soap.SOAPProcessorThread.processBody(SOAPProcessorThread.java:204)
at com.glide.processors.soap.SOAPProcessorThread.processRequest(SOAPProcessorThread.java:171)
at com.glide.processors.soap.SOAPProcessorThread.run0(SOAPProcessorThread.java:129)
at com.glide.util.ParentedThread.run(ParentedThread.java:51)

  

Cause
When the SOAP processor receives a request to access a public page, it is processed as the "guest" user. The guest user is unable to process the SOAP request, even though it is a public page. 

 

Resolution
To workaround the issue, use a database view that is not public to:
  • enable the correct user to authenticate
  • correctly evaluate against all applicable ACLs

Workaround steps:

  1. Create a database view against the table in question that is public (do not make the view public).
  2. Add read/create/write ACLs to the database view.
  3. Consume the WSDL of the database view.
  4. Run the SOAP requests against the view.
Warning: Do not add the database view to the sys_public page. This view must not be public, or the same error occurs.

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.