Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Navigating back to a form after using an "Edit" UI Action displays a page with only unstyled related lists - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Navigating back to a form after using an "Edit" UI Action displays a page with only unstyled related lists
KB0596843

Navigating back to a form after using an "Edit" UI Action displays a page with only unstyled related lists


1304 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

After clicking the Edit button on a related list and then navigating back to the form, instead of being presented with the form, a page displays containing only the related lists of the form, which appear in an unstyled manner. Instead of the form page (for example, incident.do), the related lists of the form appear (for example, list2_deferred_related_lists.do).

The following screenshots show an example.

Release

All Releases

Cause

This issue occurs in the following scenario:

  • Related List Loading is set to either On-demand or After Form Loads.
  • One or more JavaScript errors have occurred on the form.
  • The user presses the Edit button.

Resolution

To ensure this behavior does not occur, as an administrator, you should review the browser console before clicking the Edit button on forms where this issue occurs and ensure that any JavaScript errors are corrected. JavaScript errors should never occur on forms, and they can cause many other issues apart from the one described.

Some of the places where customer-defined JavaScript could cause errors on a form are:

  • Client scripts
  • UI Policies (Execute if true/Execute if false)
  • UI Scripts
  • UI Macros placed on the form using a UI Formatter

For information about identifying the cause of JavaScript errors by using the Google Chrome browser's DevTools, see the Google Developers website.

Note – JavaScript errors in the browser console have sometimes been caused by known problems. If you believe the error you are seeing is related to a known problem, raise an incident in the Now Support (HI).

Related Links

For more information about debugging client side errors check out this blog post.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.