Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Web Service Import Sets is failing with the response "soap fault: java.lang.NullPointerException" - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Web Service Import Sets is failing with the response "soap fault: java.lang.NullPointerException"
KB0565024

Web Service Import Sets is failing with the response "soap fault: java.lang.NullPointerException"


2605 Views Last updated : Jan 28, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Web Service Import Sets fail with the response "soap fault: java.lang.NullPointerException"

Problem


If the display value of a table returns an empty value, Web Service Import Sets returns soap fault: java.lang.NullPointerException.

Note: The record import happens correctly. Only the response has a display problem.

 

Symptoms


Web Service Import Sets returns soap fault: java.lang.NullPointerException on the response. Notice that reference fields to the target table show "(empty)" or nothing for those records

Cause


Most tables have an attribute set with the Display property set to true. If a new record is created or updated and the column with the Display value is set to an empty value, the result is identified by the Display value "(empty)".

As for Web Service Import Set, the results are identified by the Display value; empty results could cause the NullPointerException error.

NOTE: Display values could be caused by newly added attributes that set Display to true accidentally.

Resolution


On the target table, set the Display attribute on a non-empty column (for example, Number) to true.

For more information, see the product documentation on Web service import sets.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.